Map editor sooooooo slow

Sethington
Posts: 16
Joined: Tue Sep 29, 2015 2:48 pm

Map editor sooooooo slow

Post by Sethington » Mon Feb 29, 2016 9:06 pm

So I've tried to use the map editor to create a custom map but I gave up. Within minutes of using it it becomes some nearly unresponsive and I have to exit to game. There is no crash report. I have a GS6 and play other games with much higher processor/memory requirements (or so it would seem) with no issue. I've made sure everything else is closed and no other resource hungry apps and services are running in the background before I try it and still, after a few minutes it lags to the point of un-usability.

User avatar
DoomCarrot
Posts: 3089
Joined: Wed Mar 18, 2015 6:04 pm
Location: Commanding General's quarters, a tall keep above the mighty city of Carrot's Point

Re: Map editor sooooooo slow

Post by DoomCarrot » Mon Feb 29, 2016 10:05 pm

This happens to me to when I create a map, I have no idea why. If it starts to lag, exit to menu and go back to the editor, it should be fast again.

Also, the undo button, and "draw" button seem to cause massive amounts of lag that require restarting the editor.
The day is coming when a single carrot, freshly observed, will set off a revolution.

User avatar
Disco
Posts: 219
Joined: Sat Feb 27, 2016 4:37 pm
Location: UK

Re: Map editor sooooooo slow

Post by Disco » Sun Mar 20, 2016 1:40 pm

I have to agree. It use to be fine for me, until ive started adding triggers. It seems the more triggers I have, the more it lags (in an out of in-editor menu). Its upto about 30secs atm. Doesnt bode well when ive got another 20 or so triggers to go lol.

Does it run/check triggers everytime you open/close the menu?

Darkknight
Posts: 393
Joined: Tue Jan 13, 2015 5:01 pm
Location: The Great Castle of DarkKingdom

Re: Map editor sooooooo slow

Post by Darkknight » Sun Mar 20, 2016 3:03 pm

Everytime i use the editor to create a new map it lags really bad. But if you save and exit it works very soomthly.

User avatar
TheBluePhoenix
Posts: 1498
Joined: Thu Jul 30, 2015 5:09 pm

Re: Map editor sooooooo slow

Post by TheBluePhoenix » Sun Mar 20, 2016 4:20 pm

Well i used to find it difficult to work with, but now i am just fine after dev made some changes
BEWARE!!!!The long lost empire of phoenicia is rising- The world is but just near the golden age,wherein men played and frolicked,without any worries at all


User avatar
Disco
Posts: 219
Joined: Sat Feb 27, 2016 4:37 pm
Location: UK

Re: Map editor sooooooo slow

Post by Disco » Sun Mar 20, 2016 6:00 pm

Ive found saving, then closing the app, to open again helped lots.
Its actually pretty good again now. Though it did start to slow..but should be ok again when i re-open ;)

Lancer
Posts: 129
Joined: Fri Sep 19, 2014 6:14 pm
Location: Serbia

Re: Map editor sooooooo slow

Post by Lancer » Mon Mar 21, 2016 8:17 am

Hi,finnaly somewhone has started a post like this.
That so called Map Editor or i reffer it us Bug Editor,is reason why i stopped making maps,its just terrible,i once pressed undo buttom and it deleted HALF of he map! So i gave up on it.Phones were never meant for stuff like these,this is where tiled did well. :(

User avatar
TheBluePhoenix
Posts: 1498
Joined: Thu Jul 30, 2015 5:09 pm

Re: Map editor sooooooo slow

Post by TheBluePhoenix » Mon Mar 21, 2016 2:50 pm

Lancer wrote:Hi,finnaly somewhone has started a post like this.
That so called Map Editor or i reffer it us Bug Editor,is reason why i stopped making maps,its just terrible,i once pressed undo buttom and it deleted HALF of he map! So i gave up on it.Phones were never meant for stuff like these,this is where tiled did well. :(
It is not that bad. Sad, i liked some of your maps
BEWARE!!!!The long lost empire of phoenicia is rising- The world is but just near the golden age,wherein men played and frolicked,without any worries at all


User avatar
DoomCarrot
Posts: 3089
Joined: Wed Mar 18, 2015 6:04 pm
Location: Commanding General's quarters, a tall keep above the mighty city of Carrot's Point

Re: Map editor sooooooo slow

Post by DoomCarrot » Mon Mar 21, 2016 5:06 pm

No Lance! I liked your campaign! :(
The day is coming when a single carrot, freshly observed, will set off a revolution.

Rose
Posts: 175
Joined: Sun Feb 28, 2016 7:41 pm
Location: MS - USA

Re: Map editor sooooooo slow

Post by Rose » Sun Jun 19, 2016 12:55 am

Yea i have no probs with the map editer other than the undo button... NEVER HIT THAT BUTTON... EVER
Admire the flowering buds all you like...
However it's the thorns you need to be worried about

User avatar
DoomCarrot
Posts: 3089
Joined: Wed Mar 18, 2015 6:04 pm
Location: Commanding General's quarters, a tall keep above the mighty city of Carrot's Point

Re: Map editor sooooooo slow

Post by DoomCarrot » Sun Jun 19, 2016 8:19 pm

Ok, in my experience, NEVER EVER EVER EVEREVEREVERevereverEverEVERever hit the undo button twice. It almost always works if you make a mistake and press it once to undo it. However, if you do that, SAVE, EXIT, AND RELOAD IMMEDIATELY. If you ever press the undo button twice in one building session, it glitches out and sometimes destroys your entire map. :o
The day is coming when a single carrot, freshly observed, will set off a revolution.

Daruty
Posts: 50
Joined: Tue Feb 09, 2016 10:04 pm

Re: Map editor sooooooo slow

Post by Daruty » Mon Jun 20, 2016 9:19 pm

Once I was making a 50 x50 map but I placed one of the last units in the wrong position it looked like nothing was happening so I did some homework when I watched again I saw the last units dissapear
Never use the undo button it is evil :evil: :twisted:
EVIL VERY EVIL after that I quit aos for 2 days!!!!

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Fri Jul 15, 2016 3:04 am

DoomCarrot wrote:Ok, in my experience, NEVER EVER EVER EVEREVEREVERevereverEverEVERever hit the undo button twice. It almost always works if you make a mistake and press it once to undo it. However, if you do that, SAVE, EXIT, AND RELOAD IMMEDIATELY. If you ever press the undo button twice in one building session, it glitches out and sometimes destroys your entire map. :o

Undo button is fixed, sorry for the inconvenience!
up on server in 20 minutes.

HokanPL
Posts: 342
Joined: Sun Sep 13, 2015 10:37 pm

Re: Map editor sooooooo slow

Post by HokanPL » Sun Jul 24, 2016 12:57 am

Undo button is fixed? BTW, I will write about two problems after updating AOS on my phone:
-using undo button in map editor = CRASH
-I had on my map some green watch towers, I wanted to replace them with red ones. What happened after replacing just one? Rest are deleted, and stone walls disappeared! :shock:
And this stupid editor has saved changes automatically so I must repair a lot in my map. I WANT AN OPTION TO DISABLE AUTOSAVE AND SAVE/LOAD BUTTON, at least in map editor ( and of course communication: "do you want to quit? All unsaved changes will be lost" - or something like this)

:evil: *furious* :evil:

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Sun Jul 24, 2016 1:25 am

sounds bad.

"after updating AOS": are you updating the "dev" version?

crash: can you send me crash report? (i made 3 lotr maps in last 3 days and never had crash)

"I wanted to replace them with red ones. What happened after replacing just one? Rest are deleted, and stone walls disappeared!" please tell me detailly what you did (have u even used undo button?)

I WANT AN OPTION TO DISABLE AUTOSAVE: ok, a "quit without saving" option. ok, will be in. update: it is up on server in 20 minutes (however i had no time to test it much, only few times, i havent slept in 24 hours and was exhausting day with hours of driving back home :))

sorry for the problems, the reason of the "dev" version is to filter out such bugs, trying to prevent those bugs going out to public version (also dont forget that the public version also calls the editor "Beta")

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Sun Jul 24, 2016 1:44 am

up date on prev post.

User avatar
COOLguy
Posts: 3999
Joined: Sat Jul 12, 2014 2:58 am
Location: Nenuial, Arnor

Re: Map editor sooooooo slow

Post by COOLguy » Sun Jul 24, 2016 3:47 am

Elvenprincess and I tested it a bit each - it seems to work.

We tested Quit Game and Quit Without Save
Thanks!
Josh

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Sun Jul 24, 2016 6:51 am

Thanks!

HokanPL
Posts: 342
Joined: Sun Sep 13, 2015 10:37 pm

Re: Map editor sooooooo slow

Post by HokanPL » Sun Jul 24, 2016 12:41 pm

Reports sent. Still the same problems after update, but I suppose there is something wrong with my map, not with the app. Sorry, Daniel ;) You are lucky, because my old map without "dissappeared objects" was in own maps. I must add some triggers to correct design but it's no problem

Thanks :)

User avatar
TheBluePhoenix
Posts: 1498
Joined: Thu Jul 30, 2015 5:09 pm

Re: Map editor sooooooo slow

Post by TheBluePhoenix » Sun Jul 24, 2016 6:35 pm

HokanPL wrote:Reports sent. Still the same problems after update, but I suppose there is something wrong with my map, not with the app. Sorry, Daniel ;) You are lucky, because my old map without "dissappeared objects" was in own maps. I must add some triggers to correct design but it's no problem

Thanks :)
Yes this is not a problem with the editor, but with your map. Because by converting the towers/deleting some units you might have by mistake triggered some effect and as triggers work even while map making, you saw the effects which you thought tp be the editor's problem
BEWARE!!!!The long lost empire of phoenicia is rising- The world is but just near the golden age,wherein men played and frolicked,without any worries at all


HokanPL
Posts: 342
Joined: Sun Sep 13, 2015 10:37 pm

Re: Map editor sooooooo slow

Post by HokanPL » Mon Jul 25, 2016 9:07 am

What? Triggers are working during designing a map?
...
Everything clear :P

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Mon Jul 25, 2016 9:12 am

triggers working on editing? really? that is bug definitely - they should not work while editing.

"Reports sent." please tell me which email and from what email address of yours (i could not find them)

HokanPL
Posts: 342
Joined: Sun Sep 13, 2015 10:37 pm

Re: Map editor sooooooo slow

Post by HokanPL » Mon Jul 25, 2016 10:48 am

from michal.mulewicz@gmail.com this time (normally I use wielkikaszaniarz@gmail.com)

By the same email I've sent my map (twice, by mistake) for Paths of Rome Campaign

User avatar
Disco
Posts: 219
Joined: Sat Feb 27, 2016 4:37 pm
Location: UK

Re: Map editor sooooooo slow

Post by Disco » Mon Jul 25, 2016 1:32 pm

Triggers are not working during editing for me.

HokanPL
Posts: 342
Joined: Sun Sep 13, 2015 10:37 pm

Re: Map editor sooooooo slow

Post by HokanPL » Mon Jul 25, 2016 2:23 pm

It can't be "running triggers problem", because I got the same errors when I was adding neutral units, not connected to any trigger. It must be a bug in my map only, but don't worry - I've tested it and for players it can't be seen. :)

User avatar
TheBluePhoenix
Posts: 1498
Joined: Thu Jul 30, 2015 5:09 pm

Re: Map editor sooooooo slow

Post by TheBluePhoenix » Tue Jul 26, 2016 7:57 am

Daniel (the dev) wrote:triggers working on editing? really? that is bug definitely - they should not work while editing.

"Reports sent." please tell me which email and from what email address of yours (i could not find them)

Well i once made a trigger that when object so and so is destroyed , delete all objects from area "" . I by mistake erased the object in the condition and that immediately deleted all units in the effect area
similar things have occured with me
BEWARE!!!!The long lost empire of phoenicia is rising- The world is but just near the golden age,wherein men played and frolicked,without any worries at all


User avatar
Disco
Posts: 219
Joined: Sat Feb 27, 2016 4:37 pm
Location: UK

Re: Map editor sooooooo slow

Post by Disco » Tue Jul 26, 2016 8:26 am

TheBluePhoenix wrote:Well i once made a trigger that when object so and so is destroyed , delete all objects from area "" . I by mistake erased the object in the condition and that immediately deleted all units in the effect area
similar things have occured with me
Hahaha! Man that must have been a WTF moment! Did the undo button work?

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Tue Jul 26, 2016 8:54 am

one idea: was it an old kind TMX based map? if so modifying that can remove all units in units layer, and you need to put the rest onto it again.

HokanPL
Posts: 342
Joined: Sun Sep 13, 2015 10:37 pm

Re: Map editor sooooooo slow

Post by HokanPL » Tue Jul 26, 2016 12:30 pm

Disco wrote:Hahaha! Man that must have been a WTF moment! Did the undo button work?
When you use undo button in this situation, your app says wtf and crashes :lol:

Stratego (dev)
Site Admin
Posts: 7841
Joined: Fri Apr 25, 2014 9:28 pm

Re: Map editor sooooooo slow

Post by Stratego (dev) » Tue Jul 26, 2016 2:59 pm

Daniel (the dev) wrote:one idea: was it an old kind TMX based map? if so modifying that can remove all units in units layer, and you need to put the rest onto it again.
Is this the situation?

Post Reply

Return to “Performance problems”