I need help with the "Raid" campaign - IMPLEMENTED

Discuss anything about any map, ask for hints/help if you need
Post Reply
Juancarloszx7
Posts: 3
Joined: Mon Jul 20, 2015 11:57 pm

I need help with the "Raid" campaign - IMPLEMENTED

Post by Juancarloszx7 » Tue Jul 21, 2015 1:46 am

Hi guys,

I have been trying to complete this map but I haven't been able to, it may be that I don't understand the goal. I have read the prologue before you start the campaign over and over, but I can't seem to understand it. I have killed or convert all soldiers built the bridge, re-conquered the castle and I kept getting a message saying "You have lost the Game"

Can anyone explain very clearly what is one supposed to do? What is the objective to win that campaign?

User avatar
COOLguy
Posts: 4006
Joined: Sat Jul 12, 2014 2:58 am
Location: Nenuial, Arnor

Re: I need help with the "Raid" campaign.

Post by COOLguy » Tue Jul 21, 2015 5:36 pm

The objective should be to destroy all the enemy units, I think. So the map may have a trigger bug in it. (this is from Kirk's "Revolution" campaign, correct?)

Another thing: did you lose any of the hero units? I do know that triggers the "Lost Game" message.

Does the message appear at the same time every time? Such as after a set amount of turns, or after a set action (moving someplace, killing or losing a certain unit).
Thanks!
Josh

Juancarloszx7
Posts: 3
Joined: Mon Jul 20, 2015 11:57 pm

Re: I need help with the "Raid" campaign.

Post by Juancarloszx7 » Tue Jul 21, 2015 10:17 pm

Hey,

I sincerely appreciate you taking the time. To answer you questions, yes it is on campaign by Kirk, my heroes did not get killed, it does not happen after a set amount of turns.. I know where you are coming from with the questions..

After I kill all the units.. And nothing happens I have tried to occupy the main castle as well.. So.. The message you lost the Game happens when either

A) after destroying everything I destroy the main castle
B) after I destroy the two Towers that are near the main castle

Please help

User avatar
COOLguy
Posts: 4006
Joined: Sat Jul 12, 2014 2:58 am
Location: Nenuial, Arnor

Re: I need help with the "Raid" campaign.

Post by COOLguy » Wed Jul 22, 2015 1:43 am

Thank you for answering the questions.

I have checked the triggers, and it is not an error there.

So help make sure that I have this straight:
Juancarloszx7 wrote:A) after destroying everything I destroy the main castle
In this scenario ALL of the enemy units are destroyed (discounting passive units as walls, etc.)?
Juancarloszx7 wrote:B) after I destroy the two Towers that are near the main castle
And here, there are enemy units still alive (i.e. the large castle)?

An additional Q: This is always happening after you capture the TC on the island?

I think I shall have to test the map and see. Too bad, because I was really glad when I finished it. It takes forever to beat. :twisted:
Thanks!
Josh

Juancarloszx7
Posts: 3
Joined: Mon Jul 20, 2015 11:57 pm

Re: I need help with the "Raid" campaign.

Post by Juancarloszx7 » Thu Jul 23, 2015 2:28 pm

A) after destroying everything I destroy the main castle
In this scenario ALL of the enemy units are destroyed (discounting passive units as walls, etc.)? A= Yes

B) after I destroy the two Towers that are near the main castle
And here, there are enemy units still alive (i.e. the large castle)? A= Yes

Yes it does take forever. . I've done it like 9 times.. Just trying to complete it..

Thanks again!

am4588
Posts: 1
Joined: Tue Jul 21, 2015 9:13 pm

Re: I need help with the "Raid" campaign.

Post by am4588 » Thu Jul 23, 2015 11:16 pm

I have nearly the same problem. All enemy units dead, TC captured, castle still alive, 'you lose' after killing the last tower.

User avatar
COOLguy
Posts: 4006
Joined: Sat Jul 12, 2014 2:58 am
Location: Nenuial, Arnor

Re: I need help with the "Raid" campaign.

Post by COOLguy » Sat Aug 08, 2015 12:49 pm

Ok, yes it is bad. I've been emailing Daniel the developer, and even sent him the game 1 or 2 turns before it happens.
Thanks!
Josh

Donkey of Kong
Posts: 2
Joined: Tue Sep 08, 2015 1:20 pm

Re: I need help with the "Raid" campaign.

Post by Donkey of Kong » Tue Sep 08, 2015 3:56 pm

Chiming in that this has happened twice to me as well. The game triggered the lost message when I killed the top left tower. Has happened both times I've played it now.

User avatar
COOLguy
Posts: 4006
Joined: Sat Jul 12, 2014 2:58 am
Location: Nenuial, Arnor

Re: I need help with the "Raid" campaign.

Post by COOLguy » Wed Sep 09, 2015 3:26 am

Yes, it is awful! :( Daniel has the game, now. He will fix it as soon as he is able. Lots of other things are unfortunately eating up his time, like bugs in the map editor and the changing all existing maps to the new tileset project; and it is leaving him "swamped".

I hope he will be able to find the problem soon. :)
Thanks!
Josh

User avatar
TheBluePhoenix
Posts: 1498
Joined: Thu Jul 30, 2015 5:09 pm

Re: I need help with the "Raid" campaign.

Post by TheBluePhoenix » Wed Sep 09, 2015 6:56 pm

Yeah right dev needs another 'dev' partner cool guy :D :lol: ;)
BEWARE!!!!The long lost empire of phoenicia is rising- The world is but just near the golden age,wherein men played and frolicked,without any worries at all


Stratego (dev)
Site Admin
Posts: 8555
Joined: Fri Apr 25, 2014 9:28 pm

Re: I need help with the "Raid" campaign.

Post by Stratego (dev) » Thu Sep 10, 2015 12:22 am

ok, it took me 4 hours, but i got it... i messed it up when the mapeditor came in.

i hope it is fixed now.

please test it (sorry but u need to restart the map to test it)


up on server in 10.

Stratego (dev)
Site Admin
Posts: 8555
Joined: Fri Apr 25, 2014 9:28 pm

Re: I need help with the "Raid" campaign.

Post by Stratego (dev) » Thu Sep 10, 2015 12:24 am

you can be sure u are using the "fixed" version if u manually delete one of your heros the game will be over immediately.

Post Reply

Return to “Campaign map discussions”